Skip to main content
gamedev.net
🔒 Locked

iRC

Started by SuperRoy Jan 7, 2002 at 2:50 PM 17 replies 900+ views
Original Post
SuperRoy
SuperRoy
hey... i was thinking about making an irc client. so i talked to my friend about it and he said something about RFC...so I''m wondering if anyone knows what he''s talkin'' about. Or Maybe... If I actually get this project off the ground, would anyone like to work with me on it doing the networking? ~SuperRoy
Sup guys?
krez
krez
RFC''s are the technical definitions of stuff, like the IRC protocol, or FTP protocol, and whatnot. heh heh, how was that for a good definition?
i have no clue what the letters RFC actually stand for, and i''m sure what i just said sounds really dumb to anyone who actually knows about this... but anyways, here is a link to the IRC RFC. it''ll tell you what you need to know

--- krez (krezisback@aol.com)
--- krez ([email="krez_AT_optonline_DOT_net"]krez_AT_optonline_DOT_net[/email])
SuperRoy
SuperRoy
Thanks a lot, now...is anyone interested in doing the networking? Either WinSock or DPlay...Preferably WinSock.

~SuperRoy
Sup guys?
JonStelly
JonStelly
I don''t believe you could make an IRC client using Directplay. Directplay adds a layer on top of UDP that doesn''t allow the control that you would need to implement IRC.
krez
krez
i''d say 95% of that project will be network stuff (the rest being making a window and handling that)... so someone "helping" you would really be someone doing it for you...
but, anyways, once you get the basics of winsock down, and read through the RFC (or maybe even find a tutorial about it), it shouldn''t be too hard to do; i mean, the RFC thing will tell you what kind of data you must receive, and the format of the data you must send, and the rest is making it pretty.

--- krez (krezisback@aol.com)
--- krez ([email="krez_AT_optonline_DOT_net"]krez_AT_optonline_DOT_net[/email])
SuperRoy
SuperRoy
95% .... oi! Ok, I guess I''ll learn some WinSock.

~SuperRoy
Sup guys?
Arild Fines
Arild Fines
quote:
Original post by JonStelly
I don''t believe you could make an IRC client using Directplay. Directplay adds a layer on top of UDP that doesn''t allow the control that you would need to implement IRC.

You''d have a hard time implementing the IRC protocol in UDP anyway.



Fantastic doctrines (like Christianity or Islam or Marxism or Microsoft-bashing) require unanimity of belief. One dissenter casts doubt on the creed of millions. Thus the fear and hate; thus the torture chamber, the iron stake, the gallows, the labor camp, the psychiatric ward - Edward Abbey
--AnkhSVN - A Visual Studio .NET Addin for the Subversion version control system.[Project site] [IRC channel] [Blog]
JonStelly
JonStelly
You know, I saw that right after I posted and just KNEW that someone would bust me on it.

=p
OutAxDx
OutAxDx
Incase you guys didn''t know, IRC is a protocol, how can you implement it with another protocol, if it is one?

Arild Fines
Arild Fines
Most protocols are implemented in terms of other protocols - f.ex TCP is implemented on top of IP.

Fantastic doctrines (like Christianity or Islam or Marxism or Microsoft-bashing) require unanimity of belief. One dissenter casts doubt on the creed of millions. Thus the fear and hate; thus the torture chamber, the iron stake, the gallows, the labor camp, the psychiatric ward - Edward Abbey
--AnkhSVN - A Visual Studio .NET Addin for the Subversion version control system.[Project site] [IRC channel] [Blog]
anjee
anjee
You might have a look on planetsourcecode.com, either VB or C++ section..pages full with IRC clients/bots... might help you.
SuperRoy
SuperRoy
Hey everyone,

I downloaded a tutorial on Sockets...but I seem to be lacking the WinSock header files. (sys/socket.h,netinet/in.h,...) does anyone know where i can download these? I searched for it, and it just tells me to get the Win95 Platform SDK. But I''m sure I can get it in a smaller package than 256mb. Thanks, again.

~SuperRoy
Sup guys?
Prefect
Prefect
Actually, you''ll want winsock.h for WinSock. The header files you named are used by Berkeley Sockets (which Winsock is very similar to, unless you use WSA* functions).

cu,
Prefect
Widelands - laid back, free software strategy
Secksay
Secksay
yes, I also would be interested in knowing where I could start too look for resources on an IRC client. where did you get that tutorial on sockets superroy?
Rube
Rube
Socket''s tutorials are pretty plentiful on the web.

Do a goodle search for
"Windows Sockets Tutorial"
or "Unix Sockets Tutorial"

You''ll get plenty!

As for IRC tutorials, I''ve seen some on the net. You''re going to have to get the IRC RFC or get someone who''s broken it down into some chart or quick summary for you.

You can find the RFCs here:

http://www.ietf.org/rfc.html

I went to the index page, did a search on the page (just text) for "Internet Relay Chat" and found the following:

RFC 1459 is the old one and is updated by
RFC 2810 (Architecture)
RFC 2811 (Channel Management)
RFC 2812 (Client Protocol)
RFC 2813 (Server Protocol)

I think the first 3 will interest you in making a client.

Once you have the number, go back to the page I posted above and enter the number into the index box and it''ll pull up the RFC for you.

I know there are some fancier RFC search engines out there, but this does the job for me.

G''luck, sounds like a fun project.



R.
Rube
Rube
Hrms, maybe an OpenGL IRC client might be interesting =)

Lay out the channels and the servers in 3d, click around....probably one out there, but again, another fun idea.

R.
HJB417
HJB417
I''m a winsock newb too.

http://www.ecst.csuchico.edu/~beej/guide/net/html/ [Beej''s Guide to Network Programming]

http://u2.newcastle.edu.au/~mgdmw/socket_tutorial.html

http://u2.newcastle.edu.au/~mgdmw/server_tutorial.html

http://energon.home.mindspring.com/socket_tutorial.html [Simple, Portable, Socket Tutorial in C] <-- very handy

http://community.borland.com/article/0,1410,26223,00.html [Winsock Fundementals]

http://tangentsoft.net/wskfaq/ [Winsock Programmer''s FAQ]

http://www.vbapi.com/ref/other/winsockerror.html [Winsock Error Codes]



One problem with the programmer''''s mentality is insecurity. This goes deep. An insulting college litany says that failed mathematicians become computer programmers. They are also ridiculed for being nerdy losers, for being too fat or too skinny, and for having few social skills. Most programmers can be spotted easily in a crowd. Nobody really wants to hang out with them. Put thousands of these people in one company and if you can get them to work, you become a billionaire. -John C. Dvorak
--------------------------One problem with the programmer''s mentality is insecurity. This goes deep. An insulting college litany says that failed mathematicians become computer programmers. They are also ridiculed for being nerdy losers, for being too fat or too skinny, and for having few social skills. Most programmers can be spotted easily in a crowd. Nobody really wants to hang out with them. Put thousands of these people in one company and if you can get them to work, you become a billionai
C-Junkie
C-Junkie
IRC clients are fun to write... I''ve written two (*nix & win) as well as written a really neat bot using function pointers... eggdrop would be jealous

and lemme tell you, the RFCs are a hard read. To learn the protocol, get yourself a packet sniffer and figure out the protocol by watching another client like mIRC...

Topic Locked

This topic has been locked by a moderator. New replies are not allowed.

Sign in to reply to this topic.